вівторок, 1 січня 2013 р.

Iceweasel 3.5.X and illegal instruction

Вхідні дані:
  • 31 грудня 2012 року:
  • рідний домашній сервер, через який бігає мій інтернет;
    • На сервері крутиться Debian/GNU Linux Squeezy.
  • запущений процес оновлення системи: aptitude safe-upgrade
  • 1 січня 2013 року:
  • оновлений сервер;
  • вилітання крижаного тюленя (iceweasel) з повідомленням «Illegal instruction»;
  • повідомлення хрому (google-chrome) про те, що плагін не вдалося завантажити.


Виною всьому є останнє оновлення libflashplugin.so з якого викинуто підтримку не-SSE2 інструкцій. Чи Вас це стосується? Перелік процесорів є тут.

Ліки:
Тимчасово можна завантажити останню сумісну версію версію з репозиторію партнерів Ubuntu. Отриманий файл розпаковуємо, та копіюємо вміст до /usr/lib/mozilla/plugins 1.

Застереження:
Цілком йомвірно, що я щось упустив, оскільки не знаю Вашої конфігурації системи. На моїй все працює. Політ нормальний. Якщо виникають нюанси - пишемо в коментарях.

P.S. YouTube таки добре працює на HTML5, от тільки тепер мене мучить питання, що спричинює менше навантаження на систему, HTML5 чи Flash?




1. Перед цим у системі не повинно бути встановлених жодних інших флеш-плагінів. Для безпеки слід виконати наступні команди:
apt-get remove flashplugin-nonfree
apt-get purge flashplugin-nonfree

Немає коментарів: